File download/upload capability impacted

Incident Report for Archlet

Resolved

After passing all tests and monitoring indicating that customers are unblocked, we're resolving this incident.

For users still experiencing issues, please refresh the Archlet App page in your browser.
Posted Oct 29, 2025 - 20:45 CET

Monitoring

We applied a configuration change to bypass the Microsoft resources experiencing service degradation. Archlet App should be fully functional for all customers at this point.

We'll continue to perform tests and monitor service health.
Posted Oct 29, 2025 - 19:57 CET

Update

Microsoft identified the issue and is in the process of rolling out a patch. The patch is expected to complete within 1 hour.
Posted Oct 29, 2025 - 19:17 CET

Identified

We identified the likely root cause being a Microsoft Azure network availability issues. Microsoft is currently actively working on the issue; however, an ETA for resolution is not available yet.
Posted Oct 29, 2025 - 18:19 CET

Investigating

Starting at approximately 16:00 UTC, some users began experiencing delays or timeouts when downloading or uploading files. Further, some pages started to load slower than usual.
Posted Oct 29, 2025 - 17:15 CET
This incident affected: Data Centers (EU Data Center).